MySQL

Theme Dependency Error when you try to do a single item import

We were working on migrating a D7 site to D8 and in trying to import a View to the D8 site we got the following errors:

Configuration block.block.seven_menu_menu_draggable_views depends on the theme that will not be installed after import.
Configuration block.block.seven_system_main depends on the theme that will not be installed after import.
...
Configuration sndev.settings depends on the sndev extension that will not be installed after import.

Drupal 7.50 - Just When I Thought I Might Be Getting This Stuff

Funny thing happened with Drupal 7.50, errors started appearing that I had no clue about.  It started telling me about modules not being where they were supposed to be and about a utf-8 not being enabled.  

I was immediately frustrated by this.  All I wished to do was a "simple" upgrade and I'm getting hit with problems.  I abandoned what I was doing and went into hiding.  I have been doing drupal for coming on my 3rd year, and it seems like everytime I feel like I'm starting to get the hang of things something happens and it makes me feel like I'm back to being a beginner.